Cloudflare has confirmed that the issue is resolved. Our NOC will continue to monitor services and alert you if we see any change.
Posted Jul 02, 2019 - 10:20 CDT
Monitoring
Cloudflare has implemented a fix and affected clients are coming back up. Our NOC is continuing to monitor the situation.
Posted Jul 02, 2019 - 09:23 CDT
Identified
8:44 AM CST - Our NOC identified an issue with the Cloudflare network. Some customers are reporting intermittent website time out. We are monitoring this incident.